The temporary login issue affecting the Wello Portal and Field Service App has now been resolved. Access has been fully restored.
We apologize for the inconvenience and thank you for your patience.
If you experience any further issues, please contact our support team.
Kind regards, The Wello Solutions Team
Posted Mar 03, 2026 - 11:41 CET
Monitoring
Dear Valued Partner,
We’re currently aware of an issue preventing users from logging into the Wello portal and Field Service app.
This is due to a recent data interruption. The link between the domain and the user is not available at the moment to ensure that users are able to login correctly.
Our team is actively working to resolve the issue, and access will be fully restored within the next 30 minutes.
We sincerely apologize for the inconvenience and appreciate your patience while we fix this.
Thank you for your understanding.
Kind regards,
The Wello Solutions Team
Posted Mar 03, 2026 - 11:34 CET
This incident affected: Wello Web Application and Wello Mobile App.