Service Alert: Incident Portal Slowdown

Incident Report for Wello Solutions

Resolved

This incident has been resolved.
Posted May 12, 2025 - 10:35 CEST

Monitoring

Dear Valued Partner,

We’d like to inform you that our Wello Web Portal is currently experiencing a temporary slowdown. The root cause has been identified, and our technical team is actively working on a fix.

We truly appreciate your patience and understanding as we work to restore full performance as quickly as possible. We’ll continue to keep you updated with any important developments.

Warm regards,
The Wello Solutions Team
Posted May 12, 2025 - 09:55 CEST
This incident affected: Wello Web Application.